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COPYRIGHT

This manual and the information contained herein are the proprietary property of 
Advanced Energy Industries, Inc.

No part of this manual may be reproduced or copied without the express written 
permission of Advanced Energy Industries, Inc. Any unauthorized use of this manual 
or its contents is strictly prohibited. Copyright © 2023 Advanced Energy Industries, 
Inc. All Rights Reserved.

DISCLAIMER AND LIMITATION OF LIABILITY

The information contained in this manual is subject to change by Advanced Energy 
Industries, Inc. without prior notice. Advanced Energy Industries, Inc. makes no 
warranty of any kind whatsoever, either expressed or implied, with respect to the 
information contained herein. Advanced Energy Industries, Inc. shall not be liable in 
damages, of whatever kind, as a result of the reliance on or use of the information 
contained herein.

PRODUCT USAGE STATEMENT

  WARNING:
Read this entire manual and all other publications pertaining to the work 
to be performed before you install, operate, or maintain this equipment. 
Practice all plant and product safety instructions and precautions. Failure 
to follow instructions can cause personal injury and/or property damage. If 
the equipment is used in a manner not specified by the manufacturer, the 
protection provided by the equipment might be impaired. All personnel who 
work with or who are exposed to this equipment must take precautions to 
protect themselves against serious or possibly fatal bodily injury.

Advanced Energy Industries, Inc. (AE) provides information on its products 
and associated hazards, but it assumes no responsibility for the after-sale 
operation of the equipment or the safety practices of the owner or user. 
NEVER DEFEAT INTERLOCKS OR GROUNDS.
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TRADEMARKS

All Advanced Energy trademarks are the property of Advanced Energy 
Industries, Inc. For the list of Advanced Energy trademarks, visit: https://
www.advancedenergy.com/legal/. Any unauthorized use of Advanced Energy 
trademarks is prohibited.

All other trademarks are the property of their respective owners.

CUSTOMER FEEDBACK

Advanced Energy’s technical writing staff has carefully developed this manual using 
research-based document design principles. However, improvement is ongoing, and 
the writing staff welcomes and appreciates customer feedback. Please send any 
comments on the content, organization, or format of this user manual to:

• tech.writing@aei.com

To order a manual, please contact Technical Support:
• technical.support@aei.com
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Safety and Product Compliance 
Guidelines

IMPORTANT SAFETY INFORMATION

To ensure safe installation and operation of the Advanced Energy WaveCapture unit, 
read and understand this manual before attempting to install and operate this unit. At 
a minimum, read and follow the safety guidelines, instructions, and practices.

DANGER, WARNING, AND CAUTION BOXES

This symbol represents important notes concerning potential harm to people, this 
unit, or associated equipment. Advanced Energy includes this symbol in danger, 
warning, and caution boxes to identify specific levels of hazard seriousness.

  DANGER:
DANGER indicates an imminently hazardous situation that, if not avoided, 
will result in death or serious injury. DANGER is limited to the most extreme 
situations.
 

  WARNING:
WARNING indicates a potentially hazardous situation that, if not avoided, 
could result in death or serious injury, and/or property damage.
 

  CAUTION:
CAUTION indicates a potentially hazardous situation that, if not avoided, 
could result in minor or moderate injury, and/or property damage. CAUTION 
is also used for property-damage-only accidents.
 

PRODUCT COMPLIANCE

The following sections include information about unit compliance and certification, 
including the conditions of use required to be in compliance with the standards and 
directives.
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Product Overview

FBG SYSTEM OVERVIEW

Fiber Bragg Grating Technologies
The WaveCapture FBGA (Fiber Bragg Grating Analyzer) system is based upon a 
high-speed spectral engine simultaneously covering multiple wavelengths for precise 
and rapid Fiber Bragg Grating (FBG) sensor system measurements. It can integrate 
with an internal reference source (IRS) to achieve high end of life wavelength 
accuracy at high frequency response time. With an integrated superluminescent light-
emitting diode (SLED) and multiple channel optical switch, it can interrogate the 
fiber-optic sensing network.

The FBGA system covers a wide wavelength range and provides simultaneous 
measurements at very fast response rates and excellent wavelength resolution. High 
reliability (MIL STD 810F shock and vibration) is achieved through a rugged 
mechanical design with no moving parts. The wavelength can be calibrated with 
an internal reference source.

The Sense 20/20 software is a Microsoft Windows based program for interfacing 
with the FBGA system via a USB 2.0 connection, displaying and processing the 
spectral data. This application program is designed to run with Windows 7 or above 
operating systems. This user manual is for the Sense 20/20 application software 
version 2.3.0.4.

® WaveCapture Chapter
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SERIES OF FBGA SYSTEMS

The FBG analyzer series includes a single fiber-optic cable connected to the analyzer; 
the light source is supplied by the customer.

Figure 2‑1. FBG analyzer series

The FBGA-IRS is a spectral analyzer with an internal reference source (IRS), an 
optical switch inside, one fiber-optic cable, and a customer-supplied light source.

Figure 2‑2. FBG analyzer with internal reference source

Advanced Energy® ® WaveCapture

57010250-00AA Product Overview 2‑2

Fo
r R

el
ea

se
 6

/2
1/

20
23



The FBG Interrogator includes an integrated light source and an optical port, and can 
accommodate up to16 channels.

Optical port

Figure 2‑3. FBG Interrogator - front view

Power switch with indicator light

USB portPower input

Figure 2‑4. FBG Interrogator - rear view
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An FBGA system includes the previously described components plus a fiber-optic 
array system that is application dependent.

Power switch
Power indicator

Ethernet port (disabled)

USB port
RS-232 port (disabled)

Four optical input ports
(1x6 optical switch is purchased option)

Figure 2‑5. FBGA system with fiber-optic array
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Installation, Setup, and 
Operation

ACCESSING THE SOFTWARE PACKAGE

The installation of WaveCapture ™ FBGA System includes: Sense 20/20 software, 
USB driver for spectral engine, USB driver for SLED, and Microsoft Visual C++ 
2005 SP1 Redistributable Packages.

AE will send a secure file transfer link to download the entire software package 
needed for new FBG system users. The software package download includes 
both .zip and .7z files. You are encouraged to have 7-Zip already installed on your 
system to extract the files.

The email and downloads are time sensitive and cannot be forwarded to anyone other 
than the original recipient.

To Install the Software Package
1. In the email you received, click the secure file transfer link below the list of 

files.

2. Login or create an account with Advanced Energy Secure File Transfer.

3. Download the listed files, approximately 115 MB.

4. Extract zip folders: USB Drivers, F2096224, FBG00001.

TO INSTALL THE SLED USB DRIVER - 
OPTIONAL

If your FBGA system includes the integration of superluminescent light-emitting 
diode (SLED), follow the steps below to install the SLED USB driver.

1. Uninstall any previous version of the Silicon Laboratories USB driver through 
the control panel. 
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Figure 3‑1. Control Panel window

2. Navigate to folder C:\Sense 2020\USB Drivers\CP2101 DRIVER 
and double-click file CP210x_VCP_Win_XP_S2K3_Vista_7.exe, click 
Yes on the resulting User Account Control window to continue.

 

Figure 3‑2. User Account Control window

3. Click Next to begin.

 

Figure 3‑3. InstallShield wizard

4. Click I accept the terms of the license agreement, then click Next to continue.
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Figure 3‑4. License agreement

5. Choose Destination Location to verify where to store the files, or click 
Browse to browse to another location. Click Next to proceed.

 

Figure 3‑5. Destination location

6. Click Install to proceed. 

 

Figure 3‑6. Ready to Install the Program
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7. Once the driver is installed click Finish.

 

8. On the resulting window, click Install to install the Silicon Laboratories 
CP210x USB to UART Bridge.

 

Figure 3‑7. Bridge Driver Installer

9. Once the driver is installed, click OK to finish the installation.

Figure 3‑8. Installation complete

INSTALLING THE SPECTRAL ENGINE USB 
DRIVER

Complete the following steps to install the spectral engine USB driver.

1. Connect the FBGA system to a USB 2.0 port of the host computer using the 
USB cable provided. 

2. For the FBGA system with SLED option, plug the power cord into the line 
power socket and turn the power switch on.

Windows attempts to automatically install the spectral engine USB from its 
default system file folder.

3. Go to Window Start→ Computer, then right-click Manageto display the 
Computer Management window. Under System Tools click Device Manager 
to expand its contents. BS2BASE is listed and marked as an unknown device 
under Other devices.

Advanced Energy® ® WaveCapture
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Figure 3‑9. Computer Management window

4. Right-click BS2BASE and select Update Driver Software. 
5. In the Update Driver Software window select Browse my computer for 

driver software.

Figure 3‑10. Update Driver Software

6. In the next window, click Browse to select the file location of the 
spectral engine USB driver. The default location is C:\Sense 2020\USB 
Drivers\USB20BS Drivers\64 bits.

Advanced Energy® ® WaveCapture
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Figure 3‑11. Select driver location

7. In the resulting Window Security confirmation window, click Always trust 
software from BaySpec, Inc then click Install.

Figure 3‑12. Windows Security window

8. Wait for Windows to install the spectral engine USB driver, then click Close.

Figure 3‑13. Installation complete

VERIFYING SOFTWARE INSTALLATION

To Verify Software Installation
1. Navigate to Window Start→ Computer, then right click and select Manage 

item to bring up the Computer Management window.

Advanced Energy® ® WaveCapture

57010250-00AA Installation, Setup, and Operation 3‑6

Fo
r R

el
ea

se
 6

/2
1/

20
23



2. Under the System Tools, click Device Manager to expand its contents.

3. For the system with SLED option, under Ports (COM & LPT), a Silicon Labs 
CP210x USB to UART Bridge (COMxx) should be listed there, where xx is 
the COM port number. 

4. Under Universal Serial Bus Controllers, if the BaySpec USB20BS 
(USB20IR & USB20ACCD), product 1688 is listed, software 
installation was successful.

Figure 3‑14. Computer management

VERIFYING SYSTEM COMMUNICATION

The first action initiates a short series of automatic file loads that verify the system 
communications.

To Verify System Communication

1. Double-click Sense 2020 V1652 xxxxxxxx.exe in the folder 
C:\Sense 2020 where xxxxxxxx is the built-in time stamp of the Sense 
20/20 software. A folder C:\Sense 2020\Spectrum_Data is created 
automatically to hold saved or recorded spectrum files.

The Sense 20/20 software checks the connection between the WaveCapture 
FBGA system and the host computer and initializes the spectral engine first. 
Only a single spectral engine can be connected.
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a. Next, the Sense 20/20 software loads the system configuration from the file 
BaySpec_System.ini in the folder C:\Sense2020.

b. Then the Sense 20/20 software loads the calibration data file 
Calib_LT_########.dat, the ######## is the system serial number.

If the calibration file cannot be found or the serial number does not correlate 
with the connected system, a Load Calibration Data File dialog displays.

Figure 3‑15. Load calibration data file dialog

Click OK to acknowledge and exit the window.

TROUBLESHOOTING INITIALIZATION 
FAILURES

If the system initialization failed, most features of the Sense 20/20 software are 
disabled until the problems are remedied.

If you launch the Sense 20/20 software the following error displays "side-by-side 
configuration is incorrect" the host computer is missing the Visual C++ Runtime 
application.

Figure 3‑16. Failed to start

Installing the Microsoft Visual C++ 2005 SP1 Redistributable package on the host 
computer will remedy the issue.

To Install the VC 2005 SP1 Redistributable Package
1. Navigate to C:\Sense2020\USB Drivers\VC2005 SP1 

Redistributable Package, then double-click vcredist_x64.EXE

2. In the resulting window click Yes to accept the license agreement. 
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Figure 3‑17. Visual C++ 2005 license agreement

3. Wait for Windows to configure the redistributable package and click Yes to 
allow the application to make changes.

Figure 3‑18. Confirm install
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Communication Controls

MAIN USER INTERFACE (UI) - FUNCTIONAL 
AREA FEATURES

The following figure shows the four main components in the user interface: the 
device information tree viewer, spectrum viewer, data viewer, and menu and toolbars 
area.

Figure 4‑1. Main user interface

Device Information Tree Viewer
The device information tree viewer displays the connected FBGA system serial 
number, the wavelength range, real-time device temperatures, and the integration 
time currently used.

® WaveCapture Chapter

4

57010250-00AA Communication Controls 4‑1

Fo
r R

el
ea

se
 6

/2
1/

20
23



Figure 4‑2. Tree viewer close up

• If there is no FBGA connected, the device tree viewer will be empty.

• If there is an FBGA connected but the calibration file is not successfully loaded 
when initializing the system, only the system serial number will be shown under 
the device tree viewer and the wavelength unit will be switched to pixel.

Click X on the top right corner of this pane to close this viewer.

Spectrum Viewer
This area displays all measured spectra captured by snapshot or continuously 
acquired. The spectra are coded with user-selectable colors. You can adjust spectrum 
displays and colors associated with overlays in two ways.

• Click  or use the VIEW dropdown menu and select Set Spectrum Display 
and Color.

•

Figure 4‑3. Spectrum Display and Color Configuration window

• Check or uncheck the boxes on the left side of each overlay to enable or 
disable the spectrum and data of this overlay in both the spectrum viewer and 
data viewer. You can customize the color of each spectrum, text, marker, and 
background view using the right side color palette shown in the next figure.
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Figure 4‑4. More Colors window

To zoom in on a specific area in the spectrum viewer, left-click and hold, then drag 
the mouse to select the desired area.

Figure 4‑5. Zoom in on single spectra

Double-click the right mouse button to access graph control.

Figure 4‑7. Graph Control window

• Click Zoom out to zoom out the displayed spectra into previous fitting or 
original status in the spectrum viewer.

• Click Fit to screen to fit the displayed spectra into the spectrum viewer without 
top and bottom margins.

• Click Clear to clear spectra from the spectrum viewer.

• Click Clear measure line to remove the measurement marker and label.

• Click Set measure line at X ... to set the measure line at a specific X-axis 
value.
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Figure 4‑8. Set Measure Line window

Data Viewer - Overlay Tabs
The data viewer displays a list of spectral wavelength/pixel and intensity data, a list 
of detected peaks (if peak detection is activated), and all test parameters.

Each overlay tab would display acquired spectrum and test parameters. Click an 
overlay tab at the bottom of the data viewer to display the overlay.

Figure 4‑9. Close-up of single overlay tab

After spectrum acquisition, the overlay name with device serial number is displayed 
in the top left corner of the spectrum viewer.

Figure 4‑10. Spectrum acquisition successful

Click X in the top left corner of this pane to close the viewer.

Menu and Toolbars
You can access all of the Sense 20/20 functions and features (for example, system 
settings and spectrum acquisitions and processing information) from the menu and 
toolbars. To access features and functions, right-click the left portion of the menu or 
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toolbar to display a dropdown list. Check options to view them; uncheck options to 
close the view.

Figure 4‑11. View Preferences menu

USER INTERFACE - TOOLBARS

To customize the location of icons in any toolbar, click the downward arrow at the 
lower right end of either toolbar, then click Customize to display the Customize 
Toolbar window.

Figure 4‑12. Customize Toolbar window

• Select an icon that you want to move. Click Add to move an icon to the 
Current toolbar buttons; click Remove to move an icon to the Available 
toolbar buttons.

• Use the Move Up and Move Down buttons to change the position of the 
selected icon on the toolbar.

• Click Reset to reset all buttons to the default setting.

• Click Close to exit the customize toolbar window.

System Setting Toolbar
The system setting toolbar is located on the left side of the menu and toolbar area.
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Figure 4‑13. System setting toolbar

Save - File → Save As 

Open - File → Open

Playback Record Data - File→ Playback Record Data

Print Spectrum - File→ Print Spectrum

Data Processing - Setting→ System Settings

Set Spectrum Display and Color Configuration - View→ Spectrum Display 
and Color Configuration

Clear - Setting → Clear All Spectra and Overlays

Adjust View - View→ Spectrum Fit to Window

Calculator - Setting→ Spectrum Calculator

Version Information - Help→ About Sense 20/20

Spectrum Acquisition Toolbar
The spectrum acquisition toolbar located on the right side of the menu and toolbar 
area.

Figure 4‑14. Spectrum acquisition toolbar

Start - Acquisition→ Start Continuous Acquisition

Stop - Acquisition → Stop Continuous/Triggering Acquisition 

Snapshot - Acquisition → Snapshot One Spectrum 

Background - Acquisition → Acquire Background 

Fast Record - Acquisition → Start Fast Recording

Peak Tracking - Acquisition → Start Peak Tracking vs. Time 

Triggering - Acquisition → Start Triggering Acquisition 

GPIO - Setting → GPIO Settings
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Optical - Setting → Optical Switch Settings

IRS - Acquisition → IRS Calibration 

(SLED Off) - Setting→ Turn On SLED

(SLED On) - Setting → Turn Off SLED

POST PROCESSING TOOLS

Save Spectra

Click  in the system setting toolbar, or select Menu→ Save As to display the file 
explorer window. The default file folder is Sense 2020/Spectrum_Data.

Figure 4‑15. Save As window

You can save spectrum data as either a tab-delimited text 
Text [Tab delimited].txt or comma-delimited CSV [Comma 
delimited].csv. The automatically-generated file name is in the format 
Spectrum_SN-YYYYMMDDhhmmss.xxx for acquired spectra or Trace_SN-
YYYYMMDDhhmmss.xxx for acquired peak trace data, where:

• SN is the FBGA serial number

• YYYYMMDDhhmmss is the time stamp (year, month, day, hour, minute, second)

• xxx is the file extension (.txt or .csv)
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Click Save to save current spectra in all overlays (including the measurement 
information) into the selected directory.

The contents of a saved spectrum data file is slightly different than the contents of a 
saved trace data file. See the following tables for examples.

Table 4‑1. Contents of saved spectrum data file
Attribute Value 1 Value 2 (If Applicable)

Device_SN F1350546
Test_Time 4/24/2014 11:53:03
Integration_Time (ms) 0.08
Device_Temperature 24
Sensor_Mode High Dynamic Range
WL_Unit nm
Pwr_Unit Count
Subtract_Background Yes
Baseline_Correction No
Smoothing No
Average_Number 1
Peak_Search_Mode Uniform
Threshold 8000
Data_Count 512
WL Power
1507.6390 3097.521
1507.9938 3097.325
1507.9938 3097.118
... ...
1592.0281 3196.412
Peak_Count 2
Peak_WL Peak_Power Peak_FWHM
1552.6586 8757.768 0.6375
1555.6325 9960.831 0.5677

Table 4‑2. Contents of saved trace data file
Attribute Value 1 Value 2 (If Applicable)

Device_SN F1350546
Test_Time 4/24/2014 11:53
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Table 4‑2. Contents of saved trace data file (Continued)
Attribute Value 1 Value 2 (If Applicable)

Integration_Time (ms) 0.08
Device_Temperature 24
Sensor_Mode High Dynamic Range
WL_Unit nm
Pwr_Unit Count
Subtract_Background Yes
Baseline_Correction No
Smoothing No
Average_Number 1
Peak_Search_Mode Uniform
Threshold 8000
Trace_Sample_Count 300
Trace_Peak_Count 2
Elapsed_Time (sec) WL1 WL2
1.022 1539.9206 1559.844
1.053 1539.9207 1559.845
1.085 1539.9203 1559.844
... ...
10.443 1539.9193 1559.820

Open Saved Spectra

Click  in the system setting toolbar, or select File→ Open to access the file 
explorer window. The default file folder is Sense 2020\Spectrum_Data.
Use the Files of type drop-down menu to select file type.
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Figure 4‑16. Open saved trace files

Select saved spectrum or trace file and click Open to load spectrum data or peak 
trace data into the system. The spectrum or peak trace populates the current overlay 
selected in spectrum viewer and all data displays in the data viewer. The file name is 
shown in the top left corner of the spectrum viewer.

☞ Important
This software can also open saved spectra files when there is no FBGA device 
connected.

Print Spectra

Click  in the system setting toolbar, or select File→ Print Spectrum to send the 
spectrum viewer display to a connected printer.

Spectra Calculator

Click  in the system setting toolbar, or select Setting → Spectrum Calculator to 
invoke the calculator window.

The drop-down menu for Spectrum 1 and Spectrum 2 provide all available spectra 
for calculation.
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Figure 4‑17. Spectrum Calculator window

The drop-down menu of mathematical formulas shown in the Operator menu 
consists of the following:

Figure 4‑18. Operator drop down list

Take the following steps to utilize the calculator.

1. Select an overlay to assign to Spectrum 1 and Spectrum 2.

2. Choose an equation operator from the dropdown list.

3. If selecting one of the lower three formulas, set the value of C0.

4. Click Calculation Result (Overlay {#}) (where {#} is the numbered tab 
overlay).

The calculation results show in the spectrum viewer and in the data viewer.

The peaks of the spectrum for Overlay {#}: Calculation Result shown in 
the data viewer are searchable if the Peak Search with Uniform Threshold 
or Peak Search with Profile Threshold has been selected and the value of 
Uniform Threshold or Threshold Profile has been loaded into the system.

Click Exit to close the Spectrum Calculator window.

Playback Recorded Spectra

Click  in the system setting toolbar, or select File→ Playback Record Data. This 
will invoke the playback window.
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Figure 4‑19. Playback Saved Spectra window

The list below describe the functions of each button shown in the playback window.

Open Recorded Binary Spectrum File
Click Open Recorded Binary Spectrum File to open the file explorer 
window. The default file folder is Sense 2020\Spectrum_Data. There 
are two types of files in the drop-down menu, Record File (*.dat) and 
All Files. Select the binary Record File (*.dat) and click Open. 
The system information, test parameters, channel information {if optical switch 
is enabled and has been set to auto scan (fast record only)}, and the total 
number of spectra in this file and the first spectrum will be displayed in this 
window.

Forward and Backward 
Use the forward or backward buttons to maneuver the spectrum in the record 
file. The current spectrum line number and line stamp will be updated in the 
playback window. Changing the number in the Spectrum Line Index edit box 
will set the start spectrum when clicking the backward or forward button.

Open Wavelength Calibration File

Sense 20/20 software can open a record file with or without connecting to an 
FBGA device. If the FBGA device is connected and the calibration data is loaded 
successfully when initializing the system, the Open Wavelength Calibration File 
box is disabled and shown in gray color.

Under this situation, only the record files with the same serial number as the 
connected FBGA device can be opened. If you attempt to open a recorded file with 
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a different serial number, an error message displays, and you cannot open the file. 
Click OK to exit.

Figure 4‑20. Open Binary Spectrum File error message - device serial number does 
not match file

When the FBGA device is not connected or the FBGA device is connected without 
having loaded its calibration data successfully, you can still open the file using 
the playback record file window. After opening one record file, the horizontal axis 
shows wavelength as pixel; click Open Wavelength Calibration File and choose the 
correct calibration file. The horizontal axis then shows wavelength in nm.

If the chosen wavelength calibration file does not match the opened record file, an 
error message displays and you cannot load the calibration file. After successfully 
loading the calibration file, you can open different record files with the same serial 
number without exiting the current playback record file window. If the record files 
have a different serial number, an error message displays.

Figure 4‑21. Open Binary Spectrum File - error message - calibration and spectrum 
file serial numbers do not match

Click OK to exit, then exit the current playback record file window and re-enter it.

Add Selected Spectrum into Assigned Overlay
Select the overlay from the drop-down menu and click Add Selected 
Spectrum into Assigned Overlay to add current spectrum into the selected 
overlay.

Save Selected Spectrum into a CSV File
Click Save Selected Spectrum into a CSV File to save current opened 
binary record file into a .csv format file. The file name and location can also 
be selected in the Save As file explorer dialog window. The default file 
name will be TheName_Spectrum_####.csv where TheName matches 
the open binary record file and #### is the line stamp of current displayed 
spectrum.
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Convert Binary Spectrum File into a CSV Format
Click Convert Binary Spectrum File into a CSV Format to convert current 
opened binary record file into a .csv format file. The file name and location can 
also be selected from the Save As file explorer window. The default file name 
will match the open record binary file.

The following table shows an example of the contents of a converted text format 
spectrum data file.

Table 4‑3. Contents of a converted text format spectrum data file
Attribute Value

Device_SN F1350546
Pixel_Count 512
Integration_Time (ms) 0.08
Sample_Rate (Hz) 1000
Sensor_Mode High Dynamic Range
WL_Unit nm
Pwr_Unit Count
Subtract_Background No
Baseline_Correction No
Smoothing No
Average_Number 1
Total_Spectrum_Line 5291
Line_Index 1
Line_Stamp 2
Device_Temperature 28.86
Wavelength Power
1507.6390 3097.521
1507.9938 3097.325
1507.9938 3007.118
... ...
1592.0281 3196.412
Line_Index 2
Line_Stamp 3
Device_Temperature 28.86
Wavelength Power
1507.6390 3097.521
1507.9938 3097.325
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Table 4‑3. Contents of a converted text format spectrum data file (Continued)
Attribute Value

1507.9938 3007.118
... ...
1592.0281 3196.412
... ...

Search Peaks in the Binary Spectrum File
Click Search Peaks in the Binary Spectrum File to find peaks in all spectra 
with pre-defined uniformity or profile threshold and save search results into 
a .csv format file. If the subtract option is enabled, the current acquired 
background will be used in the data process. The file name and location can 
also be selected from the Save As file explorer window. The default file name 
will be TheName_Peak.csv where TheName matches the open binary 
record file.

The following table shows an example of a spectrum peak file.

Table 4‑4. Contents of spectrum peak file
Attribute Value

Device_SN F1350546
Pixel_Count 512
Integration_Time (ms) 0.08
Sample_Rate (Hz) 1000
Sensor Mode High Dynamic Rate
WL_Unit nm
Pwr_Unit Count
Subtract_Background No
Baseline_Correction No
Spectrum_Smoothing No
Average_Number 1
Peak_Search Uniform
Peak_Uniform_Threshold 3500
Total_Spectrum_Line 4852
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Table 4‑5. Contents of spectrum peak file (continued)
Line Line Device Peak Peak Peak Peak Peak

Index Stamp Temp Count WL1 Pwr1 WL2 Pwr2

0 0 28.86 1 1555.7067 6845
1 1 28.86 2 1555.7067 6834.5 1558.7117 7237

Track Peaks in the Binary Spectrum File
Click Track Peaks in the Binary Spectrum File to track peaks in all saved 
spectra. You need to have enabled the peak search and set threshold in the 
System Setting window.

Figure 4‑22. Confirmation to Track Peaks

Click No to abort, or Yes to invoke the peak wavelength tracking setting window.

Figure 4‑23. Peak Wavelength Tracking Setting window

• Define the peak wavelength shift range in and select desired peaks to track.

• Click OK to show the trace and data of selected peaks on the spectrum viewer 
and data viewer.

• Playback save spectra window will close automatically.

• Click No to abort peak tracking.
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When opening a record file without an FBGA device connection and you have not 
successfully loaded the calibration data first, the peak wavelength tracking setting 
window shows pixels instead of wavelength. At this point, the tracking is the pixel 
change instead of the wavelength changes over time. You will need to load the 
calibration file by opening the Open Wavelength Calibration File box, the peak 
wavelength setting window will then display wavelength and tracks changes over 
time.

The Exit button closes the playback window.

OPTIONAL FEATURE CONTROLS

IRS Calibration
If your FBGA system has the IRS calibration option, this  button in the spectrum 
acquisition toolbar and the menu path Acquisition→ IRS Calibration is enabled. 
The IRS calibration is only needed when wavelength offsets have been found.

SLED Control
If your FBGA system has the SLED option, this  button in spectrum acquisition 
toolbar, and the menu path Setting → Turn On SLED is enabled.

• Click  to turn on SLED with the output power defined in System Setting 
“Measurement and Data Processing”, and the icon will change to .

• Click  to turn off SLED and the icon reverts back to .

• Check or uncheck the item from Setting → Turn On SLED to toggle the 
SLED on or off.

GPIO Control
• If your FBGA system has the GPIO option, this icon  in the spectrum 

acquisition toolbar and the menu selection Setting→ GPIO Settings are 
enabled.

Figure 4‑24. Layout of GPIO and optical switch control pins at connector JD5
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• The six GPIO pins (G01 to G06) are located on connector JD5. They can output 
3.3 V DC TTL signals.

Figure 4‑25. GPIO setting window

• Click Exit to close the window.

Optical Switch Control
• If the FBGA system includes the optical switch option, this  button in the 

spectrum acquisition toolbar and the menu selection Setting → Optical Switch 
Settings are both enabled.

• The FBGA device can control optical switches using four IO pins (OS0 to 
OS3). This means a single optical switch can direct the light path into 2, 4, 8 
or 16 separate channels. The true value of optical switch control pins are shown 
below.

Figure 4‑26. True value table of optical switch control pins

•  This icon in the spectrum acquisition toolbar will invoke the Optical Switch 
Setting window, or alternatively, from the menu bar select Setting→ Optical 
Switch Settings to access the Optical Switch Setting window. The total optical 
switch channel number is defined in the system configuration file. All available 
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optical switch options for the fixed channel selection are listed in the Channel 
Selection drop-down menu.

Figure 4‑27. Optical Switch Setting window

• Select one channel for the optical switch in the Channel Selection drop-down 
menu. Click Set the Selected Channel to select the fixed channel for the 
optical switch.

In the auto scan queue, channel sequence is assigned, sensor mode and integration 
time for each channel is defined individually in the Setup of Auto Scan Channels 
list. The pre-defined auto scan queue for the optical switch channels can be executed 
repeatedly during fast recording acquisition.

AE strongly recommends using snapshot or continuous acquisition to optimize the 
sensor mode and integration time for each optical switch channel before engaging the 
auto scan queue.

In the auto scan queue, the maximum number of assigned channels is the total 
channel count for the optical switch. In these assigned channels, the channel order 
can either be random, or duplicated. The sensor mode has two options:

• 0: High Sensitive

• 1: High Dynamical Range

The integration time should not be less than 20 μs, and the reciprocal of the 
integration time must be larger than the sample rate.

• Click Apply Setup of Auto Scan to All Channels to duplicate the first channel 
setup across all channels.

• Click Clear Setup of Auto Scan Channel List to clear the contents in the 
Setup of Auto Scan Channels list.
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• Click Set Auto Scan Channels to set the auto scan queue from the Setup of 
Auto Scan Channels list.

If the auto scan channels for fast recording acquisition is enabled, the background, 
snapshot, continuous triggering, peak tracking and IRS acquisitions are disabled.

• Click Exit to close the Optical Switch Setting window.

MEASUREMENT AND DATA PROCESSING

System settings
You can manage spectrum acquisition and data processing settings using the System 
Setting window.

• To access system settings, click  in the system setting toolbar, or select 
Setting → System Setting. The FBGA system serial number, pixel count, 
and wavelength range displays in the top text box of the System Setting 
window. All setting parameters are read from the FBGA system and the system 
configuration file.

• Click Confirm to enable or activate all changes and close the System Setting 
window.

• Click Cancel to close the System Setting window without saving any 
parameters.

Figure 4‑28. System setting window
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Integration Time, Sample Rate, Sensor Mode, and SLED 
Settings

The integration time determines the accumulating time of spectrum acquisition. The 
longer the integration time, the higher the collected spectrum intensity. The setting 
range of the integration time is from 20 μs to 60 seconds. The integration time can be 
set by typing desired integers into the sec, ms, or μs edit boxes. If the integration time 
is too long, the spectrum intensity will be saturated.
Before setting the changed integration time into the FBGA system, integration time 
is checked with the calibration range. If out of range, the spectral ripple correction is 
disabled and the following warning displays.

Figure 4‑29. Warning message integration time out of calibration range

• The Sample Rate / Trigger Frequency determines how many spectra are 
acquired per second. Its reciprocal is the sampling time interval of spectrum 
acquisitions or scans, which must be longer than the integration time. 
Otherwise, the software is forced to increase the time interval (and therefore 
decrease the sampling rate) to make it equal to the integration time.

• During the triggering acquisition mode, use Sampling Rate / Trigger 
Frequency to input the trigger signal frequency which determines the spectrum 
data transfer speed over the USB communication channel.

• Click High Dynamic Range Mode to set the sensor into high dynamic range 
mode for measuring a strong signal.

• Click High Sensitive Mode to set the sensor into high sensitive mode for 
measuring weak signal. The acquired spectrum intensity in high sensitive mode 
is about 15 dB higher than when in high dynamic range mode.

• If the SLED option is enabled, the SLED output power setting range label and 
output power field display in this section. Modify the number within the range 
as needed to change the SLED output power.

Data Process and Display Settings
There are two wavelength units in the Wavelength Units drop-down menu: Pixel 
and nm (Wavelength). The default unit is nm (Wavelength). The relationship of 
wavelength vs. pixel is defined in the calibration data file and dependents upon the 
FBGA system temperature.

There are two power units in the Power Unit drop-down menu: Intensity in Linear 
Scale (Count) and Intensity in Logarithm Scale (dB). The default power unit is 
Intensity in Linear Scale.
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If the Acquisition Average Number is greater than one, the FBGA system makes 
the indicated numbers of spectrum acquisitions, then calculates the average of the 
acquired spectra. Averaging reduces the random noise level, but increase acquisition 
time.

While in continuous spectrum acquisition mode, the FBGA system acquires spectra 
at the indicated Acquisition Interval, valid values are 0.01 second to 3600 seconds. 
To monitor slow change activities or if you want to reduce the number of auto-saved 
spectrum files, AE recommends using a 3600 second acquisition interval.

• Uncheck the Update Overlay Data check box disables the spectrum data 
from updating in the data viewer during continuous spectrum acquisition, 
which increases the spectrum updating speed in the spectrum viewer. The last 
spectrum data and test parameters will be updated in the data viewer once 
continuous spectrum acquisition stops.

Subtract Background
Background subtraction removes the interferences from the system dark noise, 
sensor response fixed pattern, and other ambient environments.

Baseline Correction
When the baseline correction is enabled, the system calculates the baseline of 
the acquired spectrum with an auto-leveling algorithm, subtract this baseline 
from the spectrum, and shift the spectrum to make its minimum intensity zero.

Spectrum Smooth
Check this box to perform a smooth to the acquired spectrum.

Auto Save Spectrum
This enables the auto save feature in continuous spectrum acquisition or 
triggering acquisition mode. The following confirmation window displays 
when continuous spectrum acquisition or triggering acquisition starts.

Figure 4‑30. Confirm continuous mode window

Click No to abort the continuous spectrum acquisition or triggering acquisition. Click 
Yes to display the Browse for Folder window.
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Figure 4‑31. Browse For Folder window

The default file folder is Sense 2020\Spectrum_Data. You can save spectrum 
files to a different folder; to create a new folder, click Make New Folder to create a 
new folder and follow the onscreen prompts. Click OK to start continuous spectrum 
acquisition or triggering acquisition, or click Cancel to abort the operation.

During continuous spectrum acquisition, each acquired spectrum and its test 
parameters are saved into a comma- delimited text file. The file name is formatted as 
Spectrum_SN_####.csv, where SN is the serial number of the FBGA system. 
During triggering acquisition, all acquired spectra will be saved into a binary file. 
The format of the file name is described in a later section.

Check the Auto X Axis Scale check box and the X axis scale sets automatically, 
depending upon all acquired spectra. If you uncheck the Auto X Axis Scale check 
box you will need to manually set the X axis scale using the From and To edit boxes.

Check the Auto Y Axis Scale check box and the Y axis scale sets automatically, 
depending upon all acquired spectra. If you uncheck the Auto Y Axis Scale check 
box you will need to manually set the Y axis scale using the From and To edit boxes.

Peak Search Settings
• Select Disable Peak Search to disable the peak search data process.

Set the uniform threshold using the right side edit box for peak search criteria. A 
reported peak must satisfy the following conditions:

• The peak intensity must be higher than the given threshold.

• The intensity difference of two adjacent sensor pixels at the beginning of the 
rising edge of the peak must be larger than one tenth of the given threshold, 
which eliminates false peak detection caused by spectrum ripples and large 
spectral profile.
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• Select Peak Search with Uniform Threshold to perform a peak search for 
each acquired spectrum with the defined uniform threshold across all sensor 
pixels.

• Select Peak Search with Profile Threshold to bring up a file explorer window 
to pick a text format threshold profile file.

A reported peak has to meet the same two conditions mentioned above, but the 
threshold will also be given a threshold file for each pixel. The threshold profile 
will display in Overlay 16: Calculation Results of the data viewer 
and spectrum viewer. The profile file is in MS Excel comma-delimited format 
(*.csv).

Figure 4‑32. Display of the threshold profile

Figure 4‑33. Threshold profile file

The first row in the profile file is data count. If it is less than the data count of 
the searched spectrum, the zero profile thresholds will be used. The first column in 
profile is data index and the second column is the threshold.

The peak index, wavelength, power, and full width at half maximum (FWHM) of all 
found peaks will be listed in data view, and wavelength labels are displayed on top of 
each peak in spectrum view.

The Sense 20/20 software allows editing within the Peak Search setting if there is 
not a connected FBGA device, but displays the following window.
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Figure 4‑34. System not initialized warning

Click OK confirm; the System Setting window displays.

Since there is no FBGA device connection, most device information (for example, 
serial number and wavelength range) does not display. You can only adjust the Peak 
Search information.

Figure 4‑35. System Setting window with no FBGA connection

SPECTRUM ACQUISITION MODES

There are different spectrum acquisition modes to meet different measurement 
speeds. The following sections provide descriptions of each spectrum acquisition 
mode.

Advanced Energy® ® WaveCapture

57010250-00AA Communication Controls 4‑25

Fo
r R

el
ea

se
 6

/2
1/

20
23



Background Acquisition
Background acquisition has to be done manually. The background subtraction 
eliminates potential interference from the FBGA system dark noise, sensor response, 
fixed patterns, ambient environment, and provides a more accurate peak wavelength. 
When sensor modes, integration time, or environment conditions have changed, the 
background must be reacquired.

•  This icon in the spectrum acquisition toolbar initiates the background 
acquisition, or select Acquisition→ Acquire Background to achieve the same 
action.

The acquired background spectrum updates in the spectrum viewer. The 
spectrum data and test parameters are listed in the active overlay of the 
data viewer. Background subtraction can also be enabled through the System 
Setting window as well.

Snapshot Spectrum Acquisition
The snapshot spectrum acquisition allows a quick look at data processing parameters 
and the resulting measurements.

•
 This icon in the spectrum acquisition toolbar takes a snapshot of the 

spectrum, or select from the Acquisition → Snapshot One Spectrum menus to 
achieve the same action.

The acquired spectrum is then plotted in the spectrum viewer. The spectrum 
data, searched peak information, and test parameters are listed in the active 
overlay of the data viewer.

Continuous Spectrum Acquisition
Use continuous spectrum acquisition to monitor slow change events. The spectrum 
update rate in the spectrum viewer is determined by the integration time, acquisition 
interval, and display settings. To increase the spectrum update rate, decrease the 
integration time and acquisition interval, and disable the overlay spectrum data 
update in the data viewer. The maximum spectrum update rate of continuous 
spectrum acquisition is around 10 Hz.

•  The play button in the spectrum acquisition toolbar starts the continuous 
spectrum acquisition, or select menu Acquisition→ Start Continuous 
Acquisition to achieve the same action.

The acquired spectra update in the spectrum viewer after each spectrum 
acquisition is completed.

If the Update Overlay Data is enabled, the searched peaks information, or the 
spectrum wavelength and power (if the peak search is enabled), and the test 
parameters are updated in the active overlay of the data viewer.
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While the continuous spectrum acquisition is running, all buttons in spectrum 
acquisition toolbar and the system setting toolbar are disabled. Clicking on any icon 
other than the pause button produces the following warning message.

Figure 4‑36. Warning: continuous spectrum acquisition mode is enabled

Click OK to close the error message window.

•  This icon, the stop/pause button, in the spectrum acquisition toolbar pauses 
the continuous spectrum acquisition. Alternatively, you can select menu item 
Acquisition → Stop Continuous/Triggering Acquisition to achieve the same 
results.

If the Update Overlay Data is disabled, the last set of spectrum data, searched 
peak information, and test parameters are displayed in the active overlay of the 
data viewer.

Start Peak Tracking
The peak tracking vs. time function tracks the wavelength shift of selected peaks over 
time.

The FBGA sample rate is set in the System Setting dialog window, but the Sense 
20/20 program can only update acquired peak wavelength shift on the spectrum 
viewer in about 60 Hz. Meaning the on-screen peak wavelength tracking is only 
suitable for slow change events (<60 Hz). To monitor the fast change events, enable 
the fast record mode and playback.

•  This icon in the spectrum acquisition toolbar begins peak tracking. You can 
also select Acquisition → Start Peak Tracking vs. Time to achieve the same 
action. A confirmation window displays, click No to abort the peak tracking. 
Click Yes to invoke the Peak Wavelength Tracking Setting window.

• The selected peaks can only be tracked in the defined peak wavelength shift 
range. This range should not be zero or smaller than the wavelength spacing 
between adjacent FBG peaks. If multiple peaks exist in this wavelength range, 
the peak with the highest power is tracked.

• The amount of data points that can be tracked is limited to 65535. When the 
data points reach the maximum number (65535), peak tracking acquisition stops 
automatically.

• Multiple peaks are tracked simultaneously. During peak tracking, the peak 
wavelength trace is continuously updated in the spectrum viewer. During peak 
tracking, all buttons in the spectrum acquisition toolbar and the system setting 
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toolbar are disabled, except the pause/stop button. Click on any of them and an 
error message displays.

•  This icon in the spectrum acquisition toolbar stops peak tracking. The 
elapsed time vs. peak wavelength shift related to the selected peak in Peak 
Wavelength Tracking Setting window is updated in the data viewer.

Figure 4‑37. Peak tracking vs. time

This image shows the updated peak trace and data after stopping peak tracking.

•  This icon in the system setting toolbar saves the trace file. You can also 
select File→ Save As from the dropdown menus to save as well.

External Triggering Spectrum Acquisition (Optional)
• Use the external trigger acquisition to synchronize external events with FBGA 

spectrum acquisition by TTL trigger-in and generating trigger-out signal. The 
frequency range of trigger-in signal is from 1 Hz to 1000 Hz. The trigger-out 
signal is generated when the FBGA system starts to acquire spectrum. The 
width of trigger-out signal is equal to the integration time. The jitter of trigger-
out signal is about 100 μs.

• The trigger-in, trigger-out and ground pins are located on connector JD7, as 
shown below. The external trigger-in should be TTL signal. The logic low level 
of external triggering signal is lower than 0.8 V and logic high level is higher 
than 2.4 V. The maximum signal level is 5 V. If external triggering signal is 
higher than 5 V, the FBG PC board may be damaged.

Figure 4‑38. Layout of trigger-in, trigger out, and ground pins at connector JD7
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If the FBGA system has the external triggering option, the  button in the spectrum 
acquisition toolbar and menu item Acquisition→ Start Triggering Acquisition are 
enabled.

The frequency of trigger-in signals need to be set before triggering acquisition to 
optimize spectrum data transferring speed.

•  This icon in the spectrum acquisition toolbar to trigger acquisition. Or 
alternatively, select Acquisition → Start Triggering Acquisition from the 
dropdown menu to achieve the same results.

All buttons in spectrum acquisition toolbar and the system setting toolbar are 
disabled, except the pause button. A warning message displays if you click on 
any button other than the pause button during the acquisition.
Click OK to close the message.

If the Auto Save Acquired Spectrum option is disabled, the frequency of trigger-in 
signal may be very high, but the program will pick acquired spectrum at about 60 
Hz and update the spectrum in the spectrum viewer and spectrum data updates in the 
data viewer.

If the Auto Save Acquired Spectrum option is enabled, acquired spectrum is saved 
into a binary data file at the defined sample rate.

•  The pause/stop button in the spectrum acquisition toolbar stops the 
triggering acquisition. Or select Acquisition→ Stop Continuous/Triggering 
Acquisition from the dropdown menu to achieve the same result.

Fast Recording Spectrum Acquisition
Use the fast recording mode to acquire and record spectrum at very high speeds.

•  This button in the spectrum acquisition toolbar starts fast record mode. Or 
alternatively, select Acquisition→ Start Fast Recording to achieve the same 
action. A confirmation window displays, click No to abort or click Yes to start 
the fast recording acquisition.

Figure 4‑39. Fast record confirmation window

◦ The acquired spectrum raw data is saved into the binary file 
Sense2020\Spectrum_Data folder.

◦ If the host computer CPU does not have the memory or speed available, 
some of the streamed out spectrum data could be missed. Free up resources 
to the CPU by closing other application programs. The Sense 20/20 program 
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turns off all data process and spectrum updates automatically. The acquired 
spectrum data is saved into the internal memory of the host computer and a 
binary file is written with a huge block of spectrum data.

Same as with the continuous spectrum acquisition, all buttons in spectrum acquisition 
toolbar and system setting toolbar are disabled except the pause button during fast 
recording. If you click any of them, an error message displays. A warning message 
also displays on the spectrum viewer to inform updating is disabled during fast 
recording spectrum acquisition. The spectrum viewer and the data viewer are cleared 
of the warning message one fast recording mode has stopped.

Figure 4‑40. Warning message shown across spectrum viewer

•  button in spectrum acquisition toolbar pauses fast recording. The warning 
message on the top of the spectrum viewer is removed.

All acquired spectra is saved into a series of binary files with name formatted 
as:
Record_SN_YYYYMMDDhhmmssnnn_####.dat.

Each binary file can contain a maximum of 65534 spectrum lines of data. In the 
file name, SN is the FBGA serial number, YYYYMMDDhhmmssnnn is the 
time stamp of the binary file creation (YYYY: Year MM: Month, DD: Day, hh: 
hour, mm: minute, ss: second, nnn: microsecond) and #### is the accumulated 
binary file number.
During fast record, all data processing such as subtract background, baseline 
correction, or smooth and peak search, are disabled.

The spectrum data in the binary file can be reviewed or post processed in the 
Playback Saved Spectra, see “Post Processing Tools” for further information.
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FBG MEASUREMENT PARAMETERS

There are different types of Fiber Bragg Gratings (FBG) based sensors that can be 
used with the WaveCapture™ FBGA System to measure temperature pressure, strain, 
acceleration and other data parameters. These sensors are immune to electromagnetic 
interference, resistant to harsh environments and have a capability to perform 
distribution sensing.

In FBG measurements, a broadband SLED elects an input light source. By measuring 
the peak wavelength shift of reflected signal from FBG, temperature, pressure, 
or strain value are calculated. In order to achieve accurate peak wavelength, the 
following principles should be observed to optimize the measurement parameters:

• Multiple FBG sensors in serial configuration require all FBG peaks to maintain 
adequate spacing to avoid wavelength overlap during measurements.

• Set SLED to high output power range, FBGA system sensor into High 
Dynamical Range Mode, integration time at 20 μs, and the power unit as 
Intensity in Linear Scale or Intensity in Logarithm Scale. SLED works best 
in a high power level. The sensor has a quick acquisition time and lower dark 
noise in the short integration time.

• Turn on SLED, disable background subtraction, and then take a snapshot 
measurement. The optimized FBG peak intensity should be from 50000 to 
60000 counts.

• If the intensity count is larger than 65000 the FBG peak intensity is saturated. 
Reduce SLED output power or integration time to correct this issue.

• If the detected FBG peak intensity is too low, increase the integration time, 
but avoid setting integration time out of calibration range (about 40 ms in 
high dynamical range mode), during which the spectrum ripple correction is 
disabled. Switching the sensor mode to a high sensitive mode will add 15 dB 
gains compared with a sensor being in high dynamical range mode.

• To measure FBG peak wavelength, go to System Setting window select Search 
Peaks with Uniform Threshold and give peak search Threshold a valid 
numerical value. The Threshold value depends on the Power Unit. Valid 
values can be Count or dB.

• If the intensities of FBG peaks are in wide range, go to System Setting window 
select Search Peaks with Profile Threshold and matched profile threshold file.

• After selecting the optimized SLED output power, integration time, and sensor 
mode, turn off SLED and enable background subtraction. Acquire background 

using the  icon. Next, turn on SLED and take a snapshot or start continuous 
spectrum acquisition.

• You can automatically save all acquired spectra by checking Auto Save 
Acquired Spectrum in the System Setting window.

• You can monitor spectrum changes at a very low speed during continuous 
spectrum acquisition mode by setting a longer Acquisition Interval (sec).
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• To track FBG peak wavelength vs. time in continuous spectrum acquisition 
mode, select the stopwatch icon.

◦  This icon in the spectrum acquisition toolbar starts tracking peaks. Or 
select Acquisition→ Start Peak Tracking vs. Time to achieve the same 
action.

This feature can track multiple peaks. The trace of peak wavelength 
vs. elapse time (sec) is shown in the spectrum viewer, trace data and 
measurement parameters will be updated in the data viewer.

• To track FBG peak wavelength vs. time at high speed and accuracy, select the 
projector icon.

◦
 This button in the spectrum acquisition toolbar triggers the fast 

record mode to continuously acquire spectrum data. Or you can select 
Acquisition→ Start Fast Recording to achieve the same action.

Combining the time stamp in the recorded binary file name (accurate to 
millisecond) with each spectrum line stamp plus the acquisition sample rate, 
the acquisition time for each spectrum could be calculated as:
{Acquisition time = time stamp in recorded file name - (Total spectrum line 
number - spectrum line stamp) / sample rate}.

Advanced Energy® ® WaveCapture

57010250-00AA Communication Controls 4‑32

Fo
r R

el
ea

se
 6

/2
1/

20
23



 

Troubleshooting and Technical 
Support

Before requesting support, perform the recommended checks and the troubleshooting 
procedures in this chapter. If you are still unable to resolve the issue and resume 
normal operation of the equipment, contact Technical Support. You can find the 
contact information for “Technical Support” on page 5‑2.

TROUBLESHOOTING CHECKLIST

Symptom Problem Indicated Suggested Action

 
System 

initialization failed 
in starting Sense 

20/20

 
The system is not powered 
on.

 
Power on the system.

 
The USB cable between the 
host PC and system is not 
connected.

 
Check the USB cable connection, and verify 
that the host PC USB port is USB 2.0.

 
System USB drivers are not 
installed successfully.

 
Reinstall system USB drivers.

 
The host PC does not 
recognize system hardware 
immediately after boot-up.

 
Wait approximately 60 seconds after booting 
up for the host PC to recognize system 
hardware before launching the Sense 20/20 
software.

 
Missing system 
configuration file in Sense 
20/20 folder

 
Contact Technical Support

Missing wavelength 
calibration file.

Copy wavelength calibration file from 
delivered CD to Sense 20/20 folder

Cannot find FBG 
peaks

Peak signal too weak Increase peak intensity
Integration time is too short Increase integration time or set sensor to 

high sensitivity mode
The peak search threshold is 
too high

Adjust peak search threshold

FBG peak 
intensity too low

Output power of SLED is 
too low

Increase output power of SLED (see 
Optional Feature Controls)

FBG sensor is not connected 
correctly

Clean FBG sensor connector and check its 
connection

® WaveCapture Chapter

5

57010250-00AA Troubleshooting and Technical Support 5‑1

Fo
r R

el
ea

se
 6

/2
1/

20
23



Symptom Problem Indicated Suggested Action

Found too many 
peaks

Background has not be 
subtracted

Subtract the background (see Background 
Acquisition)

The peak intensity is too 
close to noise level

Subtract background and increase peak 
intensity

The peak search threshold is 
too low

Increase peak search threshold

The peak FWHM 
is 511

Background has not be 
subtracted

Subtract the background

Cannot print test 
report

Host PC is not connected to 
a printer • Connect a printer to host PC

• Print report to PDF file

• Print report to XPS viewer file

All peaks 
disappear during 
data collection

ElectroStatic Discharge 
interrupts SLED

Toggle SLED in software (see Optional 
Feature Controls)

Data acquisition 
stops and system 
does not respond 
to menu start/stop 

commands

Fast transient bursts on USB 
cable, interrupting data flow 
to computer

Add 'High Speed' USB isolator between 
USB cable and computer.

TECHNICAL SUPPORT

For help using or troubleshooting products, contact the Advanced Energy Technical 
Support Organization (TSO). Proceed as follows:

1. Make a note of the serial number (SN) and part number (PN) listed on the 
product label.

2. To contact the TSO by email, address your message to 
mailto:technical.support@aei.com. In the body of the email, include the serial 
number (SN) and part number (PN) of the product and a description of your 
problem.

3. To contact the TSO by telephone, dial +1.866.865.5180 (toll-free in the United 
States of America).

4. To contact the TSO at its business address, write to:
  AE World Headquarters
  1625 Sharp Point Drive
  Fort Collins, CO 80525 USA
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